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National Instruments: LabVIEW

LabVIEW 1is a graphical programming language that uses icons
instead of lines of text to create applications. In contrast to text-
based programming languages, where instructions determine
program execution, LabVIEW uses dataflow programming, where
the flow of data determines execution order.

You can purchase several add-on software toolkits for developing
specialized applications. All the toolkits integrate seamlessly in

LabVIEW.

http://www.ni.com
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LabVIEW Programs: Virtual Instruments (Vis)
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LabVIEW programming style

Users interact with the Front Panel when the program is running. Users
can control the program, change inputs, and see data updated in real
time. Controls are used for inputs such as, adjusting a slide control to
set an alarm value, turning a switch on or off, or to stop a program.
Indicators are used as outputs. Thermometers, lights, and other
indicators display output values from the program. These may include
data, program states, and other information.

Every front panel control or indicator has a corresponding terminal on
the block diagram. When a VI is run, values from controls flow
through the block diagram, where they are used in the functions on the
diagram, and the results are passed into other functions or indicators
through wires.



VI Front Panel
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V1 Block Diagram
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Express VIs, VIs and Functions

* Express Vls: interactive Vs with configurable dialog page
» Standard VIs: modularized Vls customized by wiring

* Functions: fundamental operating elements of Multiply
LabVIEW; no front panel or block diagram

Function

Express VI Standard VI



Labview Functions

What Types of Functions are Available?

* Input and Output

— Signal and Data Simulation

— Acquire and Generate Real Signals with DAQ

— Instrument /O Assistant (Serial & GPIB)

— ActiveX for communication with other programs
* Analysis

— Signal Processing

— Statistics

— Advanced Math and Formulas

— Continuous Time Solver

« Storage
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Controls and Functions Palettes
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Status Toolbar
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Help Options

l» Context Help

Context Help
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Online reference

« All menus online
« Pop up on functions in diagram to access online info directly




Tips for Working in LabVIEW

« Keystroke Shortcuts
—<Ctrl-H> — Activate/Deactivate Context Help Window
—<Ctrl-B> — Remove Broken Wires From Block Diagram
—<Citrl-E> — Toggle Between Front Panel and Block
Diagram
—<Ctrl-Z> — Undo (Also in Edit Menu)
* Tools » Options... — Set Preferences in LabVIEW

VI Properties — Configure VI Appearance,
Documentation, etc.



Creating a VI
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Block Diagram Window
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Creating a VI — Block Diagram
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Dataflow Programming

* Block diagram executes
dependent on the flow of data;
block diagram does NOT
execute left to right

 Node executes when data is
available to ALL input terminals

* Nodes supply data to all output
terminals when done
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Debugging Techniques

* Finding Errors

o Click on broken Run button
Window showing error appears

« Execution Highlighting

() @1 Click on Execution Highlighting button; data
flow is animated using bubbles. Values are
displayed on wires.

Right-click on wire to display probe and it
shows data as it flows through wire segment

HEF You can also select Probe tool from Tools
palette and click on wire
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File Edit

* What is a subVI?
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SubVIs

« A SubVlis a VI that can be used within another VI
« Similar to a subroutine

* Advantages
—Modular
—Easier to debug
—Don’t have to recreate code
—Require less memory



Icon and Connector

T emperature
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‘ lTemp

* An icon represents a VI in other block
diagrams

* A connector shows available
‘ terminals for data transfer



Steps to Create a SubVI

* Create the Icon
* Create the Connector
* Assign Terminals

* Save the VI
* Insert the VI into a Top Level VI




Create the Icon

* Right-click on the icon in the
block diagram or front panel
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Create the Connector

Right click on the icon pane (front panel only)
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Save The VI

* Choose an Easy to Remember Location

« Organize by Functionality
—Save Similar Vs into one directory (e.g. Math Utilities)
* Organize by Application
—Save all Vis Used for a Specific Application into one
directory or library file (e.g. Lab 1 — Frequency

Response)

« Library Files (.llbs) combine many VI's into a single file, ideal for
transferring entire applications across computers



Insert the SubVI into a Top Level VI

Accessing user-made subVils

Functions >>All Functions >> Select a VI
Or
Drag icon onto target diagram
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Loops and Charts

* For Loop

* While Loop
* Charts

* Multiplots



Loops

» While Loops &
— Have lteration Terminal
— Always Run at least Once o
— Run According to Conditional
Terminal
* For Loops
— Have lteration Terminal Chart
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Loops

1. Selecttheloop 2. Enclose code to be repeated
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Shift register

|Shift Register | [Feedback Node]

Nurneric|

I3

Numeric|

132

An 1nput of 0 would result in an output of 5 the first iteration, 10 the
second iteration and 15 the third iteration. Said another way, shift
registers are used to retain values from one iteration to the next.
They are valuable for many applications that have memory or
feedback between states.



Case Structures

* [n the Structures subpalette of Functions palette
* Enclose nodes or drag them inside the structure
 Stacked like a deck of cards, only one case visible

Functions >> Execution control




Case Structures
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State machine with Labview

State Machines

* \While Loop
* Case Structure
» Shift Register
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State machine with Labview

State Machines Transitions

« Several programming
techniques exist for transitioning
from state to state in LabVIEW
using State Machines

+ Default transition implies that
after one state, another state
always follows

f"analyzer”

* Transitions between two
potential states can be handled :
by a Select Function




Sequence Structures

* In the Execution Control subpalette of Functions palette
« Executes diagrams sequentially

* Right-click to add new frame
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Charts s G

Wwiavefarm Chart

Waveform chart — special
numeric indicator that can
display a history of values

Controls >> Graph Indicators
>> Waveform Chart

T emperature

Time




Wiring Data into Charts

Single Plot Charts Multiplot Charts
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Graphs

» Selected from the Graph palette of Controls menu
Controls>>All Controls>>Graphs

Waveform Graph — Plot an array of
numbers against their indices
Express XY Graph — Plot one array
against another

Digital Waveform Graph — Plot bits
from binary data




& Waveform Graph Properties: Waveform Graph
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Arrays & File 1/0

 Build arrays manually

* Have LabVIEW build arrays automatically
* Write to a spreadsheet file

* Read from a spreadsheet file



Adding an Array to the Front Panel

From the Controls >> All Controls >> Array and
Cluster subpalette, select the Array
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Adding an Array

Place data object into shell (i.e. Numeric Control)

i Numeric Controls
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Building an Array

+ Loops can accumulate
arrays at their boundaries
with auto-indexing

* For Loops auto-index by
default

* While Loops output only
the final value by default

* Right-click tunnel and
enable/disable auto-
indexing

Building Arrays with Loops (Auto-Indexing)

EHN
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l 1D Array Indicator
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Creating an Array with a Loop

* Loops accumulate arrays at their boundaries
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Array Functions — Basics

Functions >> All functions>> Array
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Array Functions — Build Array
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File 1/0

File I/O — passing data to and from files
- Files can be binary, text, or spreadsheet
- Write/Read LabVIEW Measurements file (*.lvm)

Writing to LVM file Reading from LVM file
: * ~ :
c8 : ' -
. Write LabWIEW ' Read LabYIEW r
» . . v Measu_rement Measurement aveform Graph|
irmulake Signal File File:
Sine ; r Signals Signals




Write LabVIEW Measurement File

* Includes the open, write, close and error handling functions

» Handles formatting the string with either a tab or comma
delimiter

* Merge Signals function is used to combine data into the
dynamic data type
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Strings

* A string is a sequence of displayable or nondisplayable
characters (ASCI|)

» Many uses — displaying messages, instrument control, file
/O

» String control/indicator is in the Controls »Text Control or
Text Indicator

Strirg String

If pou hawve large | [f pou hawve large ;
amounts of text you | amounts of text you |
can minimize the | ————® Jcan minimize the ]
space taken up by | eraea bal o on b I
the string contral by |
showing the '

scrollbar.



Clusters

 Data structure that groups data together

« Data may be of different types

* Analogous to structin C

* Elements must be either all controls or all indicators
* Thought of as wires bundled into a cable

7774




Creating a Cluster

1. Select a Cluster shell 2. Place objects inside the shell
Controls >> All Controls >> Array & Cluster
41 Al Contrals

=]
LIST Ii s

431 Array & Cluster
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Cluster Functions

 In the Cluster subpalette of the Functions>>All

functions palette

« Can also be accessed by right-clicking on the cluster
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Error Clusters

* Error cluster contains the following information:
—Boolean to report whether error occurred
—Integer to report a specific error code

to give information about the error
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Error Handling Techniques

* Error information is passed from one subVI to the next

- If an error occurs in one subVl, all subsequent subVls are
not executed in the usual manner

e Error Clusters contain all error conditions

* Automatic E m
=lal
Simple Error Handler, vi
Function
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Formula Nodes

* In the Structures subpalette

* Implement complicated equations

 Variables created at border

 Variable names are case sensitive

« Each statement must terminate with a semicolon (;)
» Context Help Window shows available functions

izap > 0 Note semicolon

y=x"2 +x 1
Input Yariable Zigkpuk Yariable
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Printing & Documentation

* Print From File Menu to Printer, HTML, Rich Text File
* Programmatically Print Graphs or Front Panel Images
* Document VIs in VI Properties » Documentation Dialog

» Add Comments Using Free Labels on Front Panel &
Block Diagram




Printing

* File » Print... Gives Many Printing Options

— Choose to Print Icon, Front Panel, Block Diagram, VI Hierarchy,
Included SubVIs, VI History

* Print Panel.vi (Programmatically Prints a Front Panel)
— Functions » All Functions » Application Control

* Generate & Print Reports (Functions » Output » Report)

Enabled? e

Feport

Additional Comments v Additional Comme
Signal 1 ooTTTTTTTTee S|gna| 1
Signal 7 seeseeecaccooy Sigral 2




Documenting VIs

* /I Properties » Documentation
—Provide a Description and Help Information for a VI

* V| Properties » Revision History
— Track Changes Between Versions of a VI

* Individual Controls » Description and Tip...
—Right Click to Provide Description and Tip Strip

» Use Labeling Tool to Document Front Panels & Block
Diagrams



Data Acquisition

DAQ Device

 Data acquisition (DAQ) basics
- Connecting Signals
« Simple DAQ application
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What Types of Instruments Can Be Controlled?

* GPIB

* Serial

* Modular Instruments

* PXI Modular Instruments
* Image Acquisition

* Motion Control

+ USB

* Ethernet

* Parallel Port

* CAN




Serial

» Serial communication transmits one bit at a time over a
transmission line

» Usually does not require external hardware

* Four parameters: baud rate, data bits, parity bit, stop
bits




Data Acquisition in Labview
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Data Acquisition

Temperature Acquisition using the DAQ Assistant

NI-DAQ B—

DAQ Assistant
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Hardware Connections

SC-20735
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Virtual Instrumentation Applications

* Design
— Signal and Image Processing
— Embedded System Programming A single graphical development platform

. (PC, DSP icrocontroller)

— Simulation and Prototyping Design Prototype Deploy
— And more...

+ Control
— Automatic Controls and Dynamic Systems
— Mechatronics and Robotics
— And more...

* Measurements

— Circuits and Electronics

— Measurements and Instrumentation

— And more...
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Next step:

LABVIEW FPGA



